re = /^[\w\d]+@[\w\d]+\.[\w\d]+$/m
str = 'contact@regex101.com
astroburgopaxxo@gmail.com
localpartgoeshere@foo.example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end