package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w\d]+@[\w\d]+\.[\w\d]+$`)
var str = `contact@regex101.com
astroburgopaxxo@gmail.com
localpartgoeshere@foo.example.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}