$re = '/^[\w\d]+@[\w\d]+\.[\w\d]+$/m';
$str = 'contact@regex101.com
astroburgopaxxo@gmail.com
localpartgoeshere@foo.example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);