using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\w\d]+@[\w\d]+\.[\w\d]+$";
string input = @"contact@regex101.com
astroburgopaxxo@gmail.com
localpartgoeshere@foo.example.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}