// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^
(?:
[+-]? # optional sign
(?: # start a conditional group
\d+ # either a nonzero number of digits
| # or a decimal phrase
\d* # optional digits preceding the decimal
\.(?=\d) # a literal decimal followed by at least one digit
\d* # optionally some more digits
) # note this group is mandatory!
(?: # start an optional scientific notation group
[eE] # the scientific notation character
[+-]? # optional sign
\d+ # after sci notation, you cannot go directly to a decimal
)?
)
$").unwrap();
let string = "67
-4
91.32
.67
-0.1123
4e5
71e-43
-323.456e-4.5
e
54e34e2
543.
43.e23
--323
e655
54e.3
-43e";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}