using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^
(?:
[+-]? # optional sign
(?: # start a conditional group
\d+ # either a nonzero number of digits
| # or a decimal phrase
\d* # optional digits preceding the decimal
\.(?=\d) # a literal decimal followed by at least one digit
\d* # optionally some more digits
) # note this group is mandatory!
(?: # start an optional scientific notation group
[eE] # the scientific notation character
[+-]? # optional sign
\d+ # after sci notation, you cannot go directly to a decimal
)?
)
$";
string input = @"67
-4
91.32
.67
-0.1123
4e5
71e-43
-323.456e-4.5
e
54e34e2
543.
43.e23
--323
e655
54e.3
-43e";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}