use strict;
my $str = '67
-4
91.32
.67
-0.1123
4e5
71e-43
-323.456e-4.5
e
54e34e2
543.
43.e23
--323
e655
54e.3
-43e';
my $regex = qr/^
(?:
[+-]? # optional sign
(?: # start a conditional group
\d+ # either a nonzero number of digits
| # or a decimal phrase
\d* # optional digits preceding the decimal
\.(?=\d) # a literal decimal followed by at least one digit
\d* # optionally some more digits
) # note this group is mandatory!
(?: # start an optional scientific notation group
[eE] # the scientific notation character
[+-]? # optional sign
\d+ # after sci notation, you cannot go directly to a decimal
)?
)
$/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}