$re = '/^
(?:
[+-]? # optional sign
(?: # start a conditional group
\d+ # either a nonzero number of digits
| # or a decimal phrase
\d* # optional digits preceding the decimal
\.(?=\d) # a literal decimal followed by at least one digit
\d* # optionally some more digits
) # note this group is mandatory!
(?: # start an optional scientific notation group
[eE] # the scientific notation character
[+-]? # optional sign
\d+ # after sci notation, you cannot go directly to a decimal
)?
)
$/mx';
$str = '67
-4
91.32
.67
-0.1123
4e5
71e-43
-323.456e-4.5
e
54e34e2
543.
43.e23
--323
e655
54e.3
-43e';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);