import Foundation
let pattern = #"NON_SYNONYMOUS_CODING\(([a-zA-Z0-9\.|>_\/]+)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"NON_SYNONYMOUS_CODING(MODERATE|MISSENSE|cTg/cAg|p.Leu270Gln/c.809T>A|506|nfkbiz|protein_coding|CODING|ENSDART00000172454|6|A|WARNING_TRANSCRIPT_NO_START_CODON),,NON_SYNONYMOUS_CODING(MODERATE|MISSENSE|cTg/cAg|p.Leu247Gln/c.740T>A|473|nfkbiz|protein_coding|CODING|ENSDART00000161190|6|A|WARNING_TRANSCRIPT_NO_START_CODON)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)