// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"NON_SYNONYMOUS_CODING\(([a-zA-Z0-9\.|>_\/]+)\)").unwrap();
let string = "NON_SYNONYMOUS_CODING(MODERATE|MISSENSE|cTg/cAg|p.Leu270Gln/c.809T>A|506|nfkbiz|protein_coding|CODING|ENSDART00000172454|6|A|WARNING_TRANSCRIPT_NO_START_CODON),,NON_SYNONYMOUS_CODING(MODERATE|MISSENSE|cTg/cAg|p.Leu247Gln/c.740T>A|473|nfkbiz|protein_coding|CODING|ENSDART00000161190|6|A|WARNING_TRANSCRIPT_NO_START_CODON)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}