const regex = /NON_SYNONYMOUS_CODING\(([a-zA-Z0-9\.|>_\/]+)\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('NON_SYNONYMOUS_CODING\\(([a-zA-Z0-9\\.|>_\\\/]+)\\)', 'g')
const str = `NON_SYNONYMOUS_CODING(MODERATE|MISSENSE|cTg/cAg|p.Leu270Gln/c.809T>A|506|nfkbiz|protein_coding|CODING|ENSDART00000172454|6|A|WARNING_TRANSCRIPT_NO_START_CODON),,NON_SYNONYMOUS_CODING(MODERATE|MISSENSE|cTg/cAg|p.Leu247Gln/c.740T>A|473|nfkbiz|protein_coding|CODING|ENSDART00000161190|6|A|WARNING_TRANSCRIPT_NO_START_CODON)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}