# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https:\/\/docs\.google\.com\/document\/d\/(.*?)\/.*?\?usp=sharing"
test_str = ("https://drive.google.com/drive/folders/1zxOcD53OqFpXDZL-4cW4a9oljlQoT7tO?usp=sharing\n\n"
"https://docs.google.com/spreadsheets/d/1Opltpx-U0jNfdSTRMUbNvsS-4TyIwk63tBrm_IsA2xA/edit?usp=sharing\n\n"
"https://docs.google.com/document/d/1F1_6E-a6RTwt9UCsH50h7naLZ6t9NhDAiK0xSYxAaE0/edit?usp=sharing\n\n"
"https://docs.google.com/document/d/1F1_6E-a6RTwt9UCsH50h7naLZ6t9NhDAiK0xSYxAaE0/edit?usp=sharing\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.