package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https:\/\/docs\.google\.com\/document\/d\/(.*?)\/.*?\?usp=sharing`)
var str = `https://drive.google.com/drive/folders/1zxOcD53OqFpXDZL-4cW4a9oljlQoT7tO?usp=sharing
https://docs.google.com/spreadsheets/d/1Opltpx-U0jNfdSTRMUbNvsS-4TyIwk63tBrm_IsA2xA/edit?usp=sharing
https://docs.google.com/document/d/1F1_6E-a6RTwt9UCsH50h7naLZ6t9NhDAiK0xSYxAaE0/edit?usp=sharing
https://docs.google.com/document/d/1F1_6E-a6RTwt9UCsH50h7naLZ6t9NhDAiK0xSYxAaE0/edit?usp=sharing
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}