use strict;
my $str = 'https://drive.google.com/drive/folders/1zxOcD53OqFpXDZL-4cW4a9oljlQoT7tO?usp=sharing
https://docs.google.com/spreadsheets/d/1Opltpx-U0jNfdSTRMUbNvsS-4TyIwk63tBrm_IsA2xA/edit?usp=sharing
https://docs.google.com/document/d/1F1_6E-a6RTwt9UCsH50h7naLZ6t9NhDAiK0xSYxAaE0/edit?usp=sharing
https://docs.google.com/document/d/1F1_6E-a6RTwt9UCsH50h7naLZ6t9NhDAiK0xSYxAaE0/edit?usp=sharing
';
my $regex = qr/https:\/\/docs\.google\.com\/document\/d\/(.*?)\/.*?\?usp=sharing/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}