#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "https:\/\/docs\.google\.com\/document\/d\/(.*?)\/.*?\?usp=sharing"
Local $sString = "https://drive.google.com/drive/folders/1zxOcD53OqFpXDZL-4cW4a9oljlQoT7tO?usp=sharing" & @CRLF & _
"" & @CRLF & _
"https://docs.google.com/spreadsheets/d/1Opltpx-U0jNfdSTRMUbNvsS-4TyIwk63tBrm_IsA2xA/edit?usp=sharing" & @CRLF & _
"" & @CRLF & _
"https://docs.google.com/document/d/1F1_6E-a6RTwt9UCsH50h7naLZ6t9NhDAiK0xSYxAaE0/edit?usp=sharing" & @CRLF & _
"" & @CRLF & _
"https://docs.google.com/document/d/1F1_6E-a6RTwt9UCsH50h7naLZ6t9NhDAiK0xSYxAaE0/edit?usp=sharing" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")