re = /(\d+(\.\d)?\,\d+(\.\d)?\|){0,2}(\d+(\.\d)?,\d+(\.\d)?)/m
str = '11.1,46.1|11.2,46.2|-14.3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end