using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+(\.\d)?\,\d+(\.\d)?\|){0,2}(\d+(\.\d)?,\d+(\.\d)?)";
string input = @"11.1,46.1|11.2,46.2|-14.3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}