package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+(\.\d)?\,\d+(\.\d)?\|){0,2}(\d+(\.\d)?,\d+(\.\d)?)`)
var str = `11.1,46.1|11.2,46.2|-14.3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}