$re = '/(\d+(\.\d)?\,\d+(\.\d)?\|){0,2}(\d+(\.\d)?,\d+(\.\d)?)/m';
$str = '11.1,46.1|11.2,46.2|-14.3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);