import Foundation
let pattern = #"(\d{5})(\d{5})(\d{5})(\d{6})(\d{5})(\d{6})(\d)(\d{14})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"26090837916945379538252700000004491630000002580"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"26090837916945379538252700000004491630000002580"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}