use strict;
my $str = '26090837916945379538252700000004491630000002580';
my $regex = qr/(\d{5})(\d{5})(\d{5})(\d{6})(\d{5})(\d{6})(\d)(\d{14})/p;
my $subst = '26090837916945379538252700000004491630000002580';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";