// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)<(?:button|input)\s+[^>]*class\s*=\s*["'][^"']*btn[^"']*[^>]*>"#).unwrap();
let string = "<button type=\"submit\" class=\"btn btn-default btn-block\">
<input type=\"button\" class=\"btn btn-default multilingual-helper\" value=\"{{ language.code.upper() }}\"/>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}