using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?:button|input)\s+[^>]*class\s*=\s*[""'][^""']*btn[^""']*[^>]*>";
string input = @"<button type=""submit"" class=""btn btn-default btn-block"">
<input type=""button"" class=""btn btn-default multilingual-helper"" value=""{{ language.code.upper() }}""/>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}