$re = '/<(?:button|input)\s+[^>]*class\s*=\s*["\'][^"\']*btn[^"\']*[^>]*>/mi';
$str = '<button type="submit" class="btn btn-default btn-block">
<input type="button" class="btn btn-default multilingual-helper" value="{{ language.code.upper() }}"/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);