const regex = new RegExp('<(?:button|input)\\s+[^>]*class\\s*=\\s*["\\'][^"\\']*btn[^"\\']*[^>]*>', 'gmi')
const str = `<button type="submit" class="btn btn-default btn-block">
<input type="button" class="btn btn-default multilingual-helper" value="{{ language.code.upper() }}"/>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}