// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(0?[1-9]|1[012])\.(0?[1-9]|[12][0-9]|3[01])\.([2-9][0-9][0-9][0-9])").unwrap();
let string = "12/12/2015";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}