re = /(0?[1-9]|1[012])\.(0?[1-9]|[12][0-9]|3[01])\.([2-9][0-9][0-9][0-9])/
str = '12/12/2015'
# Print the match result
str.match(re) do |match|
puts match.to_s
end