package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(0?[1-9]|1[012])\.(0?[1-9]|[12][0-9]|3[01])\.([2-9][0-9][0-9][0-9])`)
var str = `12/12/2015`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}