$re = '/(0?[1-9]|1[012])\.(0?[1-9]|[12][0-9]|3[01])\.([2-9][0-9][0-9][0-9])/';
$str = '12/12/2015';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);