re = /^[{]?[0-9a-fA-F]{8}[-]?([0-9a-fA-F]{4}[-]?){3}[0-9a-fA-F]{12}[}]?$/m
str = '8be94c81-a218-42f5-bf1b-383f15490d42
0C885DD3-7DD9-484B-9B20-3E6552BCA144
{0C885DD3-7DD9-484B-9B20-3E6552BCA144}
0C885DD37DD9484B9B203E6552BCA144
{0C885DD3-7DD9-484B-9B20-1E6552BCA144}
0C885DD3-7DD9484B9B203E6552BCA144
0C885DD37DD9484B9B203E6552BCA14'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end