use strict;
my $str = '8be94c81-a218-42f5-bf1b-383f15490d42
0C885DD3-7DD9-484B-9B20-3E6552BCA144
{0C885DD3-7DD9-484B-9B20-3E6552BCA144}
0C885DD37DD9484B9B203E6552BCA144
{0C885DD3-7DD9-484B-9B20-1E6552BCA144}
0C885DD3-7DD9484B9B203E6552BCA144
0C885DD37DD9484B9B203E6552BCA14';
my $regex = qr/^[{]?[0-9a-fA-F]{8}[-]?([0-9a-fA-F]{4}[-]?){3}[0-9a-fA-F]{12}[}]?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}