#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[{]?[0-9a-fA-F]{8}[-]?([0-9a-fA-F]{4}[-]?){3}[0-9a-fA-F]{12}[}]?$"
Local $sString = "8be94c81-a218-42f5-bf1b-383f15490d42" & @CRLF & _
"0C885DD3-7DD9-484B-9B20-3E6552BCA144" & @CRLF & _
"{0C885DD3-7DD9-484B-9B20-3E6552BCA144}" & @CRLF & _
"0C885DD37DD9484B9B203E6552BCA144" & @CRLF & _
"{0C885DD3-7DD9-484B-9B20-1E6552BCA144}" & @CRLF & _
"0C885DD3-7DD9484B9B203E6552BCA144" & @CRLF & _
"0C885DD37DD9484B9B203E6552BCA14"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")