import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\{]?[0-9a-fA-F]{8}[-]?([0-9a-fA-F]{4}[-]?){3}[0-9a-fA-F]{12}[\\}]?$";
final String string = "8be94c81-a218-42f5-bf1b-383f15490d42\n"
+ "0C885DD3-7DD9-484B-9B20-3E6552BCA144\n"
+ "{0C885DD3-7DD9-484B-9B20-3E6552BCA144}\n"
+ "0C885DD37DD9484B9B203E6552BCA144\n"
+ "{0C885DD3-7DD9-484B-9B20-1E6552BCA144}\n"
+ "0C885DD3-7DD9484B9B203E6552BCA144\n"
+ "0C885DD37DD9484B9B203E6552BCA14";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}