re = /<(?<tagName>\w+)(?<attributes>.*?)>(?<body>.*)<\/\w+>/m
str = ' <child name = "child_name1" type = "child_type1">test</child>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end