using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?<tagName>\w+)(?<attributes>.*?)>(?<body>.*)<\/\w+>";
string input = @" <child name = ""child_name1"" type = ""child_type1"">test</child>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}