$re = '/<(?<tagName>\w+)(?<attributes>.*?)>(?<body>.*)<\/\w+>/m';
$str = ' <child name = "child_name1" type = "child_type1">test</child>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);