package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<(?<tagName>\w+)(?<attributes>.*?)>(?<body>.*)<\/\w+>`)
var str = ` <child name = "child_name1" type = "child_type1">test</child>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}