re = /\s+|,|\s-+\s|:|;|\(|\)|(\s+|^)'|'(\s+|$)|^'|"|\.{3}/m
str = '\'Alice was beginning...to "get" very tired of sitting by her sister on the\'
bank, and of (having) nothing to do: once-or-twice she had peeped into the
book her sister was reading, but --- it had no pictures or conversations in
it, \'and what is the use of a book,\' thought Alice \'without pictures or
conversation?\'
But my banana ate it. Dammit! ugh.'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result