# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s+|,|\s-+\s|:|;|\(|\)|(\s+|^)'|'(\s+|$)|^'|\"|\.{3}"
test_str = ("'Alice was beginning...to \"get\" very tired of sitting by her sister on the'\n"
"bank, and of (having) nothing to do: once-or-twice she had peeped into the\n"
"book her sister was reading, but --- it had no pictures or conversations in\n"
"it, 'and what is the use of a book,' thought Alice 'without pictures or\n"
"conversation?'\n\n"
"But my banana ate it. Dammit! ugh.")
subst = "\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.