import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+|,|\\s-+\\s|:|;|\\(|\\)|(\\s+|^)'|'(\\s+|$)|^'|\"|\\.{3}";
final String string = "'Alice was beginning...to \"get\" very tired of sitting by her sister on the'\n"
+ "bank, and of (having) nothing to do: once-or-twice she had peeped into the\n"
+ "book her sister was reading, but --- it had no pictures or conversations in\n"
+ "it, 'and what is the use of a book,' thought Alice 'without pictures or\n"
+ "conversation?'\n\n"
+ "But my banana ate it. Dammit! ugh.";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}