const regex = /\s+|,|\s-+\s|:|;|\(|\)|(\s+|^)'|'(\s+|$)|^'|"|\.{3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+|,|\\s-+\\s|:|;|\\(|\\)|(\\s+|^)\'|\'(\\s+|$)|^\'|"|\\.{3}', 'gm')
const str = `'Alice was beginning...to "get" very tired of sitting by her sister on the'
bank, and of (having) nothing to do: once-or-twice she had peeped into the
book her sister was reading, but --- it had no pictures or conversations in
it, 'and what is the use of a book,' thought Alice 'without pictures or
conversation?'
But my banana ate it. Dammit! ugh.`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);