// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9a-fA-F]{1,4}:){7}[0-9a-fA-F]{1,4}").unwrap();
let string = "centos7
centos7.local
centos7.com.au
192.168.128.3
2001:8003:4c22:6701:e123:9395:629:8866";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}