using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9a-fA-F]{1,4}:){7}[0-9a-fA-F]{1,4}";
string input = @"centos7
centos7.local
centos7.com.au
192.168.128.3
2001:8003:4c22:6701:e123:9395:629:8866";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}