$re = '/([0-9a-fA-F]{1,4}:){7}[0-9a-fA-F]{1,4}/m';
$str = 'centos7
centos7.local
centos7.com.au
192.168.128.3
2001:8003:4c22:6701:e123:9395:629:8866';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);