const regex = /([0-9a-fA-F]{1,4}:){7}[0-9a-fA-F]{1,4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9a-fA-F]{1,4}:){7}[0-9a-fA-F]{1,4}', 'gm')
const str = `centos7
centos7.local
centos7.com.au
192.168.128.3
2001:8003:4c22:6701:e123:9395:629:8866`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}