re = /^(([0-2][1-9]\.((0[1-9])|1[0-2]))|((3[0,1])\.((0[1,3-9])|(1[0-2]))))\.(\d{4})/m
str = '11.01.2022
29.02.2022
.02.2022
99.99.2022
31.01.2021
30.01.2021'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end