const regex = /^(([0-2][1-9]\.((0[1-9])|1[0-2]))|((3[0,1])\.((0[1,3-9])|(1[0-2]))))\.(\d{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([0-2][1-9]\\.((0[1-9])|1[0-2]))|((3[0,1])\\.((0[1,3-9])|(1[0-2]))))\\.(\\d{4})', 'gm')
const str = `11.01.2022
29.02.2022
.02.2022
99.99.2022
31.01.2021
30.01.2021`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}