import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([0-2][1-9]\\.((0[1-9])|1[0-2]))|((3[0,1])\\.((0[1,3-9])|(1[0-2]))))\\.(\\d{4})";
final String string = "11.01.2022\n"
+ "29.02.2022\n"
+ ".02.2022\n"
+ "99.99.2022\n"
+ "31.01.2021\n"
+ "30.01.2021";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}