// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\+)?(0|27)([5-9])([0-9])( )?([0-9]{3})( )?([0-9]{4})$").unwrap();
let string = "+27827860965
27827860965
0827860965
034567891
082 786 0965
+2782 786 0965
2782 786 0965";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}