using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+)?(0|27)([5-9])([0-9])( )?([0-9]{3})( )?([0-9]{4})$";
string input = @"+27827860965
27827860965
0827860965
034567891
082 786 0965
+2782 786 0965
2782 786 0965";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}